PyQt, Pyside, Qt Creator and Maya…

Frustrating! Nothing like spending almost half a day trying to get PyQt working with Maya. Here I am thinking that Maya includes PyQt, whereas I don’t have to do a thing to get it working. Call me stupid, but when I read “be aware that with Maya 2015, there is no more need to build PySide as it is coming by default in Maya, nor you have to rebuild Qt itself as the main Qt tools to build PyQt are now included in the Maya distributions”, I take that to mean there is not much I have to do in order to start some GUI scripting with PyQt. But no, this doesn’t work:

import PyQt4.QtCore as qc
import PyQt4.QtGui as qg

Error: ImportError: file line 1: No module named PyQt4.QtCore

Apparently I still need to do all of this, even though some part of Qt is included….   >:(

So I decided, screw it.. I will just jump ship over to PySide.  I’ve heard it’s similar enough.  I just want to say a big thanks to Brecht Lecluyse for this great writeup on starting off with PySide.  It really helped a lot.  Now onto some Qt Creator and GUI fun.

Leave a Reply

Your email address will not be published. Required fields are marked *